Wednesday, January 13, 2010

CodeWeavers CrossOver 9.0 coming soon

I thought I would give our readers the heads up about the soon to be released CrossOver 9.0. CodeWeavers CrossOver 9.0 is slated for launch sometime towards the end of January beginning of February 2010 and represents a major step forward for the CrossOver product. At this time no definite release date is scheduled, but it should be within the next month or so.

First, CrossOver 9.0 contains many fixes to existing applications, and just generally makes the product better. As of this writing CrossOver has been merged with Wine 1.1.34 and contains many improvements for Internet Explorer, Microsoft Office, Quicken, PhotoShop and many other supported and none supported applications.

Second, the folks at CodeWeavers have re-written the entire user interface from scratch, and have created what they feel is a more intuitive installation process and user experience. The new user interface is written in GTK and the look and feel is much more intuitive then the older Tcl/TK UI that was used before this upcoming release.

Third, and perhaps most important, the CrossOver installer will now be directly linked to our online Compatibility database and allow people to install unsupported software via (recipes) contained on the Compatibility Center.

This will make the product much easier to use for beginners if a recipe exists for an application, the Compatibility database will download the recipe and automatically install the users application for them. Likewise, CrossOver power users will be able to upload recipes to the Compatibility database to help other CrossOver users in the future. Taken together, this will offer CodeWeavers CrossOver customers a substantially better experience with the product.

Product pricing and availability is slated to remain the same as of the time of this writing.

1 comment:

Anonymous said...

I'm running Crossover 8.0.3 on an elderly Red Hat Enterprise Linux WS 4 update 3.

The new GTK interface looks great, but I fear this means that Crossover 9 won't run on RHEL 4. Is this correct?