Tuesday, January 1, 2008

Running MS Office 2003 under Linux with Wine 0.9.52

This Page Has Been Moved: Please Note the New Location Below

We restructured the whole site and this page no longer exists on this location. The page that your looking for has been moved to a different Web address on the new and improved Wine-Reviews.net Site:

http://www.wine-reviews.net/ or the original post


Click on the link above to go to the new location. (To maintain accessibility, we have not set up automatic redirection to the new page.) If you have a bookmark to the old page, please change it to the new address above. If you followed a link from another Web site to this page, please let the people responsible for that Web site know the new location above. If you are having trouble finding the information you want, do a search on this article at our new site.

Thanks for your understanding and Sorry for the inconvenience.

The Editors at Wine-Reviews

35 comments:

Uma said...

I dont see the difference between the two installation procedures?

twickline said...

Removed:
Next up is to set the Owner and Organization in the registry.

$ regedit

Now set the Owner and Organization in:
[Software\\Microsoft\\Windows\\CurrentVersion]
[Software\\Microsoft\\Windows NT\\CurrentVersion]

Added:
imm32.dll section

the average person doesnt like regedit :D so im sure they will like this...

I used the same screenshots to save space...

dannybuntu said...

Hi, your guide has been very helpful to me. I hope that someday someone will be able to make a program for this like envy for nvidia.

ubuntuFan said...

dannybuntu,
it would be even better to collaborate in the project like
http://www.wine-doors.org/

Anonymous said...

Hi Tom,

there's a good chance that with latest wine git you won't need native imm32 any more. At least it fixes the Excel 2003 Viewer for me.

Regards - Michael

Anonymous said...

Hi, I seem to have the problem that I don't find richedit20 etc but rather riched20 (wine 0.9.53 Ubuntu 7.10)

Kiran Vangaveti said...

Did anyone ever get Outlook 2003 to work on Wine !!??? That is the only thing keeping me in windows.

KK

aceq said...

thank you :)

aceq said...

i have install sucsessfully !:)

wine 0.9.53
Fedora Core4 x32bit

Kiran Vangaveti said...

aceq, do you mean you got outlook working on wine 0.9.5. Did you face any problems?any words of wisdom.

Anonymous said...

Can you post information on how to setup file associations for word with .doc etc once the install is complete. Here is a like on how to do it.
http://ubuntuforums.org/showthread.php?t=586846&page=2

Jihad said...

Hurra. We're in 2008 and finally we can run Office 2003. With this pace will be running Office 2007 in... 2012. Hooray.

Don't see what's so great about the latest Wine release. I installed Office 2003 last summer on Ubuntu with Wine. No biggie. What *WOULD* rock is Office 2007!

Jihad said...

Ooh. Was a bit fast there. Didn't install 2003, but Office XP. Whole other thing... BUT I SAW YOUR OFFICE 2007 INSTALL. AMAZING!

hasi said...

Does anyone know which is the best centralized place to find info about which wine version does what for office (and other programs)?
The Word page at winehq.org does not contain much info. When I post, there are rarely answers. Then, there is "http://www.wine-forum.org/", but that seems to be relatively new, not much there, yet.

I get Office (Word/PPT/Excel) installed with 0.9.53 on a naked wine, without any additional tricks (no MSXML3, riched30). So, what is the reason for installing those? However, I still find that Word runs better on 0.9.37 (embedded jpeg/PNG images are rendered very slow, I had issues with font rendering: everything looked bold, although it wasn't). I use playonlinux.com to switch between wine versions.
Any info?

Anonymous said...

When we run setup it ends up installing the whole suite irrespective of what we select. How do we get this to install only Word, Excel & PPT ?

hasi said...

dear "anonymous":
I cannot confirm your problem: in my case, only Word, PPT and Excel get installed. I have to emphasize that I not only unselected the other applications (Outlook, etc.), but I have also checked "Detailed customized settings" (or something similar) and made my detailed selections.
--hasi

Michael Croes said...

I just installed Office 2003 with Darwine (0.9.55), didn't set any dlls as native and it all worked. It seems everything got installed though, just like some other people mentioned here. Other than that it works fine.

René said...

Currently I am running MS Office 2003 under Wine 0.9.54 on an ASUS EEE. It works except for one aspect. Pictures in jpg format are not shown in Word and PowerPoint documents. You only see an empty box with a cross in it. Vector graphics are shown correctly. Is there a way to show jpg's correctly under Office 2003 using Wine?

Regards - René

4ndy said...

Just XLNT. works perfectly!
Thx

Anonymous said...

No need to overcomplicate:
Ubuntu hardy
wine-0.9.58
(fresh install)
Install word viewer:
http://www.microsoft.com/downloads/details.aspx?familyid=95E24C87-8732-48D5-8689-AB826E7B8FDF&displaylang=en

Add excel and powerpoint viewers
Run setup from office CD

You're done!
No hacking needed

twickline said...

The howto was for 0.9.52 and at that time it wasnt the case :D

Tom

b said...

i've managed to install without a problem, but i can't seem to activate the product.

any tips?

the info at WineHQ has not helped me :-(

thanks!

Carlos Hernan said...

Hi. I have wine-0.9.46 and I'm trying to install Office 2003 but I still have a problem concerning to the user: "Microsoft Office Word hasn't installed for current user. Execute the installation program again to install the application".
Any suggestions?

gilangs said...

Hi. I've tried it and..it works! But the problem is that when I have successfully installed Flash MX and Photoshop 7, I can't run them. They just show their splash image. Any suggestion(s)?

Ravinder said...

Hi Tom,

After reading your excellent article i thought it looked straightforward enough for a newbie like me to try. However, I'm struggling to even get wine working! After installing the latest debian version 0.9.58 on an eee pc 900 (20gb linux), when i call up wine (winecfg), I get the following:

/home/user> winecfg
ALSA lib seq_hw.c:457:(snd_seq_hw_open) open /dev/snd/seq failed: No such file or directory

However, the wine window still comes up as though everything is fine

Where am i going wrong?

twickline said...

Hello Ravinder,

That error is harmless, you can proceed as if you never seen it.. trust me your going to see tons of errors and fixme's if you watch the terminal...

Ravinder said...

OK. Took your advice and ignored it. Thought I'd try something simple to double check wine was working (like sol.exe) and it works!

Next step:

mount -t iso9660 -o unhide /dev/cdrom /media/cdrom0

I'm being told only root can do that. Tried "su -l" (i bought a book), which then asks for a password. But it won't let me enter a password (or any characters, for that matter). Would the password be the same one i use to log in at startup? (i haven't set any others)

As someone later in the article commented, I downloaded the xlviewer, wdviewer and ppt viewer - does this mean I don't need the MSMXL?

And my last dumb question - how do I get the MS Office cd to run the installation procedure?

All help gratefully received!

twickline said...

Just mount the CD as a normal CD then, Ubuntu doesn't give normal root privileges as a default config.

You can try it with a builtin MSXML dll, but if it doesn't work, you will need this package from MS.

-Tom

Ravinder said...

Many thanks Tom,

Figured out how to get into the root

sudo su -

It would appear the problem with running the cd is not just me, but specific to the version of linux running on the eee pc 900:

http://forum.eeeuser.com/viewtopic.php?pid=264611#p264611http://forum.eeeuser.com/viewtopic.php?pid=264611#p264611

Trying to mount a cd (with an eternal drive connected via usb) results in the following message:

/home/user/My Documents> mount /dev/cdrom
mount: can't find /dev/sr0 in /etc/fstab or /etc/mtab

Any thoughts?

twickline said...

If I were you I would find a local linux user group ;) .. As I have no idea about the eeepc, I would like to have one, one of these days tho... :D

Hamdani Amin said...

have the problem with powerpoint slideshow been resolved? I manage to install office 2003 that the only problem I had ecountered.

Ravinder said...

Even with my limited experience, I still recommend them (although the battery is not great). Many thanks for all your help.

Xierxes said...

Hi,

Thanks for the great guide. I have Office2003 installed, but I am having some problems with Access. I am confident that it is related to the system.mdw file for security, although I cannot identify exactly where. Does anybody have any hints? The AppDb and other searches reveal that it should work, although this seems to be a common problem.

Cheers

jacobgrocks said...

when i try it on wine 1.0rc3, i get "Setup ended prematurely because of an error" after i select options. I am using Kubuntu 8.04 x86_64.

JayTeeGee said...

I have the same problem as jacobgrocks. The install won't even start. There is a quick flash of the install screen, then it disappears. I'm using Hardy and wine 1.0. I'm new to Linux so I'm not too capable yet. Any suggestions?