Thursday, November 29, 2007

Halo: Combat Evolved on Linux with Wine

This Page Has Been Moved: Please Note the New Location Below

We restructured the whole site and this page no longer exists on this location. The page that your looking for has been moved to a different Web address on the new and improved Wine-Reviews.net Site:

http://www.wine-reviews.net/ or the original post


Click on the link above to go to the new location. (To maintain accessibility, we have not set up automatic redirection to the new page.) If you have a bookmark to the old page, please change it to the new address above. If you followed a link from another Web site to this page, please let the people responsible for that Web site know the new location above. If you are having trouble finding the information you want, do a search on this article at our new site.

Thanks for your understanding and Sorry for the inconvenience.

The Editors at Wine-Reviews

9 comments:

Vadi said...

Woah. I'll definitely give a try, thanks!

haloluver said...

What version of wine did you use?

twickline said...

0.9.49

Anonymous said...

works perfectly if you use a joystick instead of a mouse. actually played through the entire game on wine that way. mouse movement problems really render this game otherwise unplayable.

Anonymous said...

Alright, how did you get it to work. I followed your steps exactly and Halo installed, but when the screen loads, I can hear the background music, but the area with the Halo logo across the top, and the Campaign, Multiplayer, Profiles, Settings, Credits, and Quit all have white boxes over them and no mouse control. Could you help me out with this?

Anonymous said...

Same here; Fedora x86_64 wine 0.9.58 (I believe I tried 0.9.49 and got the same on it too). I update to every new release just to see if Halo Demo works. If they can get the demo to work I will probably buy the game. I have installed directx9.0 march 2008 and still got the white boxes over the menu items (got white boxes with or without directx) Could you please help us.

twickline said...

Hello,

What video card do you have?
I have a Nvidia 8800 here.. I will re install the demo again in a day or so and see what its doing now.

Anonymous said...

I have an ATI Radeon X1050 PCI Express video card. It comes with a catalyst control center. It is certified for windows vista. I think it is a very nice graphics card. Halo says [We're sorry the game did not exit correctly should it be run in safe mode?] It detected a 64M Nvidia GeForce3 (0x0200) video card. Why?

Anonymous said...

It sorta worked for me.

I'm using Ubunto 7.10 with an nVidia 6600 AGP 512MB video card.

I switched to su or root user to install.
After I enter the wine HaloTrialSetup.exe command in the terminal, it takes a few minutes for the install window to appear.
It installs ok and setup is ok.

The graphics, sound and mouse are a bit choppy or laggy, but still playable.
The only texture that was wrong was the ocean, everything else looked ok.

I'm using the proprietary nvidia driver that comes with Ubuntu.

Maybe the driver that I downloaded from nvidia.com would work better if I could only figure out how to install it.

When I try to install the driver it says I have to exit X.
When I reboot into the recovery/console and try to install the nvidia driver, it says I have to install it from X.

Can anyone tell me how to install the nvidia driver in Ubuntu for the nvidia 6600 agp video card???