Sunday, September 16, 2007

Running MS Office 2003 under Linux with Wine

This Page Has Been Moved: Please Note the New Location Below

We restructured the whole site and this page no longer exists on this location. The page that your looking for has been moved to a different Web address on the new and improved Wine-Reviews.net Site:

http://www.wine-reviews.net/ or the original post


Click on the link above to go to the new location. (To maintain accessibility, we have not set up automatic redirection to the new page.) If you have a bookmark to the old page, please change it to the new address above. If you followed a link from another Web site to this page, please let the people responsible for that Web site know the new location above. If you are having trouble finding the information you want, do a search on this article at our new site.

Thanks for your understanding and Sorry for the inconvenience.

The Editors at Wine-Reviews

23 comments:

klattimer said...

Running the setup again to fix the "not installed for this user issue" doesn't seem to fix it. I've been battling against this problem since wine 0.9.43, which it didn't work on. Any chance we can lock down the cause of this issue together?

Please get in contact with me via the wine-doors.org site

Thanks.

yt said...

Office 2003 on wine 0.9.45.
I've tried to update/repair, but the dialog box "Microsoft Office (Word or Excell) has not been installed for the current user. Please run setup to install the application" appears again. And Office does't start.

Dejan said...

I'm just saying thank you for the great tutorials!

Also, I'm rather happy to see you getting involved in wine-doors, which looks like a rather promising project.

Keep up the good work!

Anonymous said...

the first line of your tutorial says :
tom@tom:~$ wine richedit30.exe

but where do you get richedit30.exe ?

i searched ms-downloads - no luck !

Peter said...

I ran the tutorial with both version 0.9.43 and 0.9.45 and run into the same "not installed for this user" error. Although some things that were different is that I could not install via "wine setup." It just didn't exist. Instead I ran wine "setupstd" which gives me the option of installing the standard packages. Any help would be appreciated

Anonymous said...
This comment has been removed by a blog administrator.
somnath pal said...

Good article. I am also using Office2000 with win 0.9.36 & it works like charm.

twickline said...

richedit 3.0 update link

Anonymous said...

Worked through guide but stuck at entering product key.

I click on Next and two messages pop up.

1. The source media is corrupted
2. The product key is incorrect.

I'm sure this is not true as I have installed disk on windows.

Is there something wrong with my wine setup?

pepe

wonko said...

everything worked fine. word is starting correctly but keeps telling me "microsoft word has not been installed for the current user" and quits. I searched the web and found lota people with the same problem but so solution. however, as i found out it has something to do with the registries. removing (or renaming) HKEY_LOCAL_MACHINE\Software\Microsoft\Office\11.0\Registration
makes word ask for user name, organization and serial but quits after you hit ok. next time you run word it asks again. switching back to the old registries word again keeps telling me that it "has not been installed for the current user". dunno what to do, need it for compatibility but don't have windows installed...

adonet said...

Installatin works fine. I installed the Dutch version of MS Office 2003 pro. But winword starts, and crashes after a few seconds. Excel and powerpoint are not installed for the current user. That is not repaired with the install repair.
Any suggestions would be appreciated.

twickline said...

Hello,

Install Wine 0.9.37 and i'm 99% sure it will work. there has been some regressions in the msi.dll since 0.9.38

Anonymous said...

Great guide.

Excel and powerpoint works - but sadly Word does not.
It exists with this:
fixme:imm:ImmGetOpenStatus (0x183430): semi-stub
fixme:imm:ImmReleaseContext (0x1004a, 0x183430): stub
X Error of failed request: BadAlloc (insufficient resources for operation)
Major opcode of failed request: 53 (X_CreatePixmap)
Serial number of failed request: 2668
Current serial number in output stream: 2683

This is with wine 0.9.37

twickline said...

Major opcode of failed request: 53 (X_CreatePixmap)
Serial number of failed request: 2668
Current serial number in output stream: 2683

----

reboot your box and try it again and word should start working.

new media said...

Hey, thanks for the guide, worked for me but with one modification as explained at WineHQ to resolve the Not installed for this user error.

“Simply install with Wine 0.9.46. When you launch any program, it will say that the program isn’t installed for the current user. Don’t panic. Remove Wine (”sudo aptitude remove wine” for me). Install Wine 0.9.37. Launch any program. It will work. Now update your Wine version to 0.9.46, relaunch the programs, and…. Magic! It works."

One unfortunate issue though, Word keeps crashing on me when I try to save as. Open and save work the first time only, the second time I try to open or save a file Word crashes, save as always crashes. Is anybody else facing this? A search on Google and WineHq has elicited little information on this so far.

Jeremy said...

I degraded to 0.9.37, ran winword.exe - same problem with 'not installed for current user'. Notepad.exe worked. Upgraded back to 0.9.46 an dI still have the same problem. It teases b/c the error dialog takes 2-3 seconds to appear - makes me think it will work "this time".\\I'm on Ubuntu 7.10 AMD64.

Rutger said...

I also degraded to 0.9.37, and now it works! Only indeed the 'save as' in Word doesn't...

I run Ubuntu 7.10 - AMD64. I downloaded the 0.9.37 from WineHQ. First uninstall wine, then install the .deb, then restart computer, then run word.... Voila!

Sérgio said...

Installed in Ubuntu 7.10, wine .9.48. Got user issue. Downgraded to .9.37, ran word, excel, without a hitch. Upgraded to .9.48 and everything works just fine. Some sorcery at work! Thanks a lot!

Chris said...

I got Office2003 to work on Wine 0.9.49 by doing this Tut but also editing the Regedit at:

HLM\Software\Microsoft\Office\11.0\Registration\

You will find a long Number Folder like this: {90023423-6000... Click on that and edit the SmartSourceDir to point to the Source of Office11 Folder which you installed from. I rip my Office to my Linux Box and made a Drive Mapping to point D:\ to home/user/office11 folder.

Anonymous said...

There is a 'Licensing' section missing. When added, the application will ask you to register instead of saying it was installed for the wrong user.

If this comment goes through, I'll post the mod.

Anonymous said...

My openSuse 10.3 came with 9.44, this version doesn't work. I tried wine 0.9.51, and it still doesn't work. Both version did the as stated below #2.

1. Where can I get 0.9.37 for openSuse 10.3?
2. When I installed the Office 2003, toward the end of the setup, the setup logged me off the system and I have to logon again. Is this normal? I would expect the Office Setup tell me the Office installation is completed instead, but apparently NOT.

Justin said...

I managed to get Office 03 to install using wine, but when I run it, instead of "english", I get "<<<<<<" marks as the font...anyone else run into that?

Alex said...

I know good tool is working with MS Word-repair word 2007, sometimes these files contain tens of pages with critical, sometimes confidential data, all operations take only several minutes and are performed in three mouse clicks, can work with .doc, .docx, .dot and .dotx files and with any version of Microsoft Word text editor, tool can recover only plain text, it means, that text formatting, graphics and all other elements will be lost, tool can recover your data from corrupted *.doc files, located on corrupted media: floppy and CD disks, flash and zip drives, etc.